Conditional Menus

Omschrijving

Conditional Menus is a simple yet useful WordPress plugin by Themify, which allows you to swap the menus in the theme as per specific conditions. In short, you can have different menus in different posts, pages, categories, archive pages, etc. It works with any WordPress theme that uses the standard WordPress menu function.

How to use it

Once you activate the plugin, you will see the conditional menus on the Manage Locations tab located in your WP Admin > Appearance > Menus page.

1) To add conditional menu: click “Conditional Menu” and select a menu from the list (you can create these menus in the “Edit Menus” tab)
– You can remove the menu by selecting “Disable Menu” from the list.
2) Click on “+ Conditions” to add conditions in the modal box (tick the checkboxes where you want the menu to appear)
3) To remove the conditional menus, click on the “X” button

Visit https://themify.me/conditional-menus for more details.

Schermafdrukken

  • Admin interface

Installatie

  1. Login to your wp-admin > go to Plugins > Add New and upload the ‘conditional-menus.zip’
  2. Activate the plugin

Beoordelingen

2 maart 2021
i looked here, i looked on your website, no where is a example/demo what the condition are, so why bother to install it not knowing if this is the right plugin for me
26 januari 2021
Works exactly how I expected and hoped. Very happy with this.
15 november 2020
Everything looked great at first and actually everything is working fine in absolute terms. But we don't know why the menus keep reappearing. Maybe a conflict with the astra theme or a plugin. In any case I uninstalled and found a much more efficient solution for my menu display.
Lees alle 50 beoordelingen

Bijdragers & ontwikkelaars

“Conditional Menus” is open source software. De volgende personen hebben bijgedragen aan deze plugin.

Bijdragers

Vertaal “Conditional Menus” naar jouw taal.

Interesse in ontwikkeling?

Bekijk de code, haal de SVN repository op, of abonneer je op het ontwikkellog via RSS.

Changelog

1.1.9 (2020.12.11)

  • Fix: Compatibility with PHP 8